Bug #85

Drqman leaks shared memory

Added by Andreas Schröder over 8 years ago. Updated over 8 years ago.

Status:FixedStart date:
Priority:NormalDue date:
Assignee:Redmine Admin% Done:

0%

Category:drqman
Target version:0.64.4

Description

After the exit of Drqman the number of used shared memory segments increases by 1. This can be reproduced (and further increased) by starting and stopping Drqman several times.

Commenting out

[[CreateComputersPage]](notebook,info);

prevents the error. So it seems to be caused by fetching computer structs which include shared memory segments.

History

#1 Updated by Andreas Schröder over 8 years ago

  • Status changed from New to Fixed
  • Resolution set to fixed

The problems was in fetching a list of computers without throwing away their shared memory segments and doing it again for displaying details of one computer.

Changeset 3128 seems to fix this.

Also available in: Atom PDF