Bug #51

opened file leak in request.c: request_job_frame_info

Added by Redmine Admin almost 10 years ago. Updated almost 10 years ago.

Status:FixedStart date:
Priority:HighDue date:
Assignee:Redmine Admin% Done:

0%

Category:all
Target version:0.64.4

Description

request_job_frame_info opens a file and forgets to close it. This causes both the drqman and the python bindings to crash after a long usage.

I attach a patch (although the solution is simply a close of sfd at the end of the function)

I reproduced it on 0.64.x, although it seems to be present in the trunk also.

patch_0.64.x.patch Magnifier - Patch for the file leak (273 Bytes) Redmine Admin, 06/12/2008 10:43 am

History

#1 Updated by Andreas Schröder almost 10 years ago

  • Status changed from New to Fixed
  • Resolution set to fixed

I've found several other places in request.c where the file descriptor was not closed. All occurencies should be fixed in trunk now.

Also available in: Atom PDF