Bug #34

memory leaks in SWIG interface files

Added by Andreas Schröder over 10 years ago. Updated almost 8 years ago.

Status:FixedStart date:
Priority:HighDue date:
Assignee:Redmine Admin% Done:

0%

Category:all
Target version:0.64.4

Description

There are memory leaks in the SWIG interface files (both Ruby and Python). It seems to be caused by the code of the typemaps.
In Gonzalo Garramuño's opinion, "malloc/memcpy should not be used. That memory allocated by malloc is afaik never being released (and cannot be released sanely by a ruby free_func as it was allocated as block)."

History

#1 Updated by Andreas Schröder over 9 years ago

  • Status changed from New to In progress

Seems to be fixed for Ruby. See http://drqueue.org/cwebsite/drqueue_community/comments.php?DiscussionID=493 for progress on this bug.

#2 Updated by Andreas Schröder over 9 years ago

  • Status changed from In progress to Fixed
  • Resolution set to fixed

I closing this ticket because only the Python bindings seem to be affected.

See ticket #43 for more information.

#3 Updated by Redmine Admin over 9 years ago

  • Status changed from Fixed to Feedback
  • Resolution deleted (fixed)

That's not a resolution for Python, I guess. As long as there are Python bindings, bug should not be marked as fixed if it's not fixed for them.

I'd like to know more opinions regarding the memory allocation issue (regarding Python) as I share the feeling of it being caused by the fact of being allocated as a block and not individually.

I do not know how to do it properly and would like to know to make it right.

#4 Updated by Redmine Admin over 9 years ago

  • Status changed from Feedback to New

If it doesn't affect Ruby, as kaazoo is taking care of Ruby I'll take care. G-d's willing.

#5 Updated by Andreas Schröder over 9 years ago

OK. This ticket depends on ticket #43. Sadly Trac doesn't seem to support bug dependencies.

So we will close this one when the other ticket is fixed.

#6 Updated by Andreas Schröder almost 8 years ago

  • Status changed from New to Fixed
  • Resolution set to fixed

Python memory leak ticket is closed.
Ruby bindings seem to not be affected.
Will close this ticket for now until new memory leaks in the bindings are found.

Also available in: Atom PDF